<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML+RDFa 1.0//EN"  "http://www.w3.org/MarkUp/DTD/xhtml-rdfa-1.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <!--[if IE]><![endif]-->
<link rel="dns-prefetch" href="//fonts.gstatic.com" />
<link rel="preconnect" href="//fonts.gstatic.com" crossorigin="" />
<link rel="preconnect" href="//fonts.googleapis.com" />
<link rel="dns-prefetch" href="//fonts.googleapis.com" />
<link rel="preconnect" href="//stats.g.doubleclick.net" />
<link rel="dns-prefetch" href="//stats.g.doubleclick.net" />
<link rel="dns-prefetch" href="//www.google-analytics.com" />
<link rel="preconnect" href="//www.google-analytics.com" />
<link rel="preconnect" href="//ajax.googleapis.com" />
<link rel="dns-prefetch" href="//ajax.googleapis.com" />
<link rel="preconnect" href="//cdn.rawgit.com" />
<link rel="dns-prefetch" href="//cdn.rawgit.com" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="description" content="Hasbro has gotten all out today revealing several new toys for the ever popular Star Wars brand. The biggest announcement is a Vintage Collection style Razor Crest as well as several new Black Series figures. The Razor Crest from The Mandalorian will be a part of Haslab. This means the project will only go ahead if there are over 6000 backers. As of time of writing, there are" />
<meta name="keywords" content="Star Wars, Razor Crest, hasbro, Black Series, The Mandalorian" />
<meta name="news_keywords" content="Star Wars, Razor Crest, hasbro, Black Series, The Mandalorian" />
<link rel="canonical" href="https://emptylighthouse.com/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875" />
<link rel="shortlink" href="https://emptylighthouse.com/node/35127" />
<meta property="fb:pages" content="251062578360943" />
<meta property="og:title" content="Hasbro Reveals Razor Crest Toy And Other New Star Wars Figures" />
<meta property="og:site_name" content="Empty Lighthouse Magazine" />
<meta property="og:description" content="Hasbro has gotten all out today revealing several new toys for the ever popular Star Wars brand. The biggest announcement is a Vintage Collection style Razor Crest as well as several new Black Series figures. The Razor Crest from The Mandalorian will be a part of Haslab. This means the project will only go ahead if there are over 6000 backers. As of time of writing, there are well over 4000 backers so the project will be successful. It comes with a 3.75 inch scale Razor Crest as well as a Mandalorian figure with his Beskar armor." />
<meta property="og:type" content="article" />
<meta property="og:updated_time" content="2020-09-26T02:56:05-04:00" />
<meta property="og:url" content="https://emptylighthouse.com/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875" />
<meta property="og:see_also" content="Star Wars: The Rise of Skywalker Still On Top Of The Box Office" />
<meta property="og:see_also" content="1917 Beats Star Wars: The Rise of Skywalker At The Box Office" />
<meta property="og:see_also" content="Fans Choose The Next Lego UCS Star Wars Set" />
<meta property="og:see_also" content="Kathleen Kennedy Says A Woman Will Direct A Star Wars Film" />
<meta property="og:see_also" content="Star Wars: The Rise of Skywalker Blu-ray and Digital HD Release Dates Revealed" />
<meta property="og:see_also" content="Hasbro To Still Make Star Wars And Marvel Toys" />
<meta property="og:see_also" content="How Emperor Palpatine Was Revived In Star Wars: The Rise of Skywalker" />
<meta property="og:see_also" content="Star Wars: The Rise of Skywalker Is The Least Successful Sequel Trilogy Movie" />
<meta property="og:see_also" content="Hot Toys Reveals New Figure From Solo: A Star Wars Story" />
<meta property="og:see_also" content="LEGO Star Wars: The Skywalker Saga Release Date Announced" />
<meta property="og:see_also" content="Mark Hamill Reflects On Star Wars Fanbase and His Experience With The Sequels" />
<meta property="og:see_also" content="Star Wars Celebration 2020 Has Been Canceled" />
<meta property="og:see_also" content="Lego Reveals New Star Wars Sets To Be Out This Year" />
<meta property="og:see_also" content="Star Wars: Squadrons Gameplay Trailer Released" />
<meta property="og:see_also" content="Avengers: Endgame Director Would Like To Tackle A Star Wars Movie" />
<meta property="og:see_also" content="Star Wars: The Bad Batch Cartoon Coming In 2021" />
<meta property="og:see_also" content="Star Wars: The Clone Wars Getting Black Series Toys" />
<meta property="og:see_also" content="New Star Wars The Vintage Collection Millennium Falcon Announced By Hasbro" />
<meta property="og:see_also" content="Lego Star Wars Holiday Special Coming To Disney+" />
<meta property="og:see_also" content="Disney/Lucasfilm Taking A Step Back From Star Wars Movies" />
<meta property="og:see_also" content="Star Wars: Squadrons Single Player Trailer Released" />
<meta property="og:see_also" content="Star Wars: The Rise of Skywalker Jet Trooper Hot Toys Revealed" />
<meta property="og:see_also" content="Star Wars UCS Mos Eisley Cantina Lego Set Revealed" />
<meta property="og:see_also" content="Mattel Reveals New Babu Frik Plush From Star Wars: The Rise of Skywalker" />
<meta property="og:see_also" content="Star Wars Qui Gon Jinn Figure Revealed By Hot Toys" />
<meta property="og:image" content="https://emptylighthouse-production.s3-us-west-2.amazonaws.com/s3fs-public/field/image/star-wars-hasbro-razor-crest-no-panel-front-j832f.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Hasbro Reveals Razor Crest Toy And Other New Star Wars Figures" />
<meta name="twitter:url" content="https://emptylighthouse.com/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875" />
<meta name="twitter:description" content="Hasbro has gotten all out today revealing several new toys for the ever popular Star Wars brand. The biggest announcement is a Vintage Collection style Razor Crest as well as several new Black Series" />
<meta name="twitter:image" content="https://emptylighthouse-production.s3-us-west-2.amazonaws.com/s3fs-public/field/image/star-wars-hasbro-razor-crest-no-panel-front-j832f.jpg" />
<meta property="article:publisher" content="https://www.facebook.com/EmptyLighthouse/" />
<meta property="article:tag" content="Star Wars" />
<meta property="article:tag" content="Razor Crest" />
<meta property="article:tag" content="hasbro" />
<meta property="article:tag" content="Black Series" />
<meta property="article:tag" content="The Mandalorian" />
<meta property="article:published_time" content="2020-09-26T02:56:05-04:00" />
<meta property="article:modified_time" content="2020-09-26T02:56:05-04:00" />
<meta itemprop="name" content="Hasbro Reveals Razor Crest Toy And Other New Star Wars Figures" />
<meta itemprop="description" content="Hasbro has gotten all out today revealing several new toys for the ever popular Star Wars brand. The biggest announcement is a Vintage Collection style Razor Crest as well as several new Black Series figures. The Razor Crest from The Mandalorian will be a part of Haslab. This means the project will only go ahead if there are over 6000 backers. As of time of writing, there are well over 4000 backers so the project will be successful. It comes with a 3.75 inch scale Razor Crest as well as a Mandalorian figure with his Beskar armor." />
<meta itemprop="image" content="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/android-icon-192x192.png" />
<meta name="dcterms.title" content="Hasbro Reveals Razor Crest Toy And Other New Star Wars Figures" />
<meta name="dcterms.creator" content="Damian Seeto" />
<meta name="dcterms.description" content="Hasbro has gotten all out today revealing several new toys for the ever popular Star Wars brand. The biggest announcement is a Vintage Collection style Razor Crest as well as several new Black Series figures. The Razor Crest from The Mandalorian will be a part of Haslab. This means the project will only go ahead if there are over 6000 backers. As of time of writing, there are well over 4000 backers so the project will be successful. It comes with a 3.75 inch scale Razor Crest as well as a Mandalorian figure with his Beskar armor." />
<meta name="dcterms.date" content="2020-09-26T02:56-04:00" />
<meta name="dcterms.type" content="Text" />
<meta name="dcterms.format" content="text/html" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="dcterms.identifier" content="https://emptylighthouse.com/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875" />
<link rel="shortcut icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-57x57.png" type="image/png" />
<link rel="icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/favicon-16x16.png" sizes="16x16" />
<link rel="icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/favicon-96x96.png" sizes="96x96" />
<link rel="icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/android-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-60x60.png" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-72x72.png" sizes="72x72" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-76x76.png" sizes="76x76" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-114x114.png" sizes="114x114" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-120x120.png" sizes="120x120" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-144x144.png" sizes="144x144" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-152x152.png" sizes="152x152" />
<link rel="apple-touch-icon" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-180x180.png" sizes="180x180" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-57x57.png" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-72x72.png" sizes="72x72" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-76x76.png" sizes="76x76" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-114x114.png" sizes="114x114" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-120x120.png" sizes="120x120" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-144x144.png" sizes="144x144" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-152x152.png" sizes="152x152" />
<link rel="apple-touch-icon-precomposed" href="https://emptylighthouse.com/sites/all/themes/emptylighthouse/icons/apple-icon-180x180.png" sizes="180x180" />
  <title>Hasbro Reveals Razor Crest Toy And Other New Star Wars Figures | Empty Lighthouse Magazine</title>
  <script type="text/javascript">
<!--//--><![CDATA[//><!--
for(var fonts=document.cookie.split("advaggf"),i=0;i<fonts.length;i++){var font=fonts[i].split("="),pos=font[0].indexOf("ont_");-1!==pos&&(window.document.documentElement.className+=" "+font[0].substr(4).replace(/[^a-zA-Z0-9\-]/g,""))}if(void 0!==Storage){fonts=JSON.parse(localStorage.getItem("advagg_fonts"));var current_time=(new Date).getTime();for(var key in fonts)fonts[key]>=current_time&&(window.document.documentElement.className+=" "+key.replace(/[^a-zA-Z0-9\-]/g,""))}
//--><!]]>
</script>
<style type="text/css" media="all">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</style>
<noscript id="advagg_loadcss_1">
<link type="text/css" rel="stylesheet" href="https://emptylighthouse.com/sites/default/files/advagg_css/css__Lv3jJss6KFwykPoClkAziBYSSlXgng_UdkswFfz7b3I__ha5KCdmnd5ObDoeHfPAr7PwP0YUBCBnCbjUqzrGnhPM__X3J5iaTDAJV5jEkMptZUC44ftTNfpiOKLspZWdcu7A8.css" media="screen" />
</noscript><link type="text/css" rel="preload" href="https://emptylighthouse.com/sites/default/files/advagg_css/css__Lv3jJss6KFwykPoClkAziBYSSlXgng_UdkswFfz7b3I__ha5KCdmnd5ObDoeHfPAr7PwP0YUBCBnCbjUqzrGnhPM__X3J5iaTDAJV5jEkMptZUC44ftTNfpiOKLspZWdcu7A8.css" media="screen" as="style" onload="window.advagg_mod_loadcss = function() {if (window.jQuery) {if (jQuery.isFunction(jQuery.holdReady)){jQuery.holdReady(false);}} else {setTimeout(advagg_mod_loadcss, 100);}};setTimeout(advagg_mod_loadcss, 200);this.onload=null;this.rel=&#039;stylesheet&#039;" />
  <script type="text/javascript">
<!--//--><![CDATA[//><!--
/*eslint-disable */
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-37862014-1", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>

  <script type="text/javascript">
window.is_mobile = false;
(function(a,b){if(/(android|bb\d+|meego).+mobile|avantgo|bada\/|blackberry|blazer|compal|elaine|fennec|hiptop|iemobile|ip(hone|od)|iris|kindle|lge |maemo|midp|mmp|mobile.+firefox|netfront|opera m(ob|in)i|palm( os)?|phone|p(ixi|re)\/|plucker|pocket|psp|series(4|6)0|symbian|treo|up\.(browser|link)|vodafone|wap|windows ce|xda|xiino/i.test(a)||/1207|6310|6590|3gso|4thp|50[1-6]i|770s|802s|a wa|abac|ac(er|oo|s\-)|ai(ko|rn)|al(av|ca|co)|amoi|an(ex|ny|yw)|aptu|ar(ch|go)|as(te|us)|attw|au(di|\-m|r |s )|avan|be(ck|ll|nq)|bi(lb|rd)|bl(ac|az)|br(e|v)w|bumb|bw\-(n|u)|c55\/|capi|ccwa|cdm\-|cell|chtm|cldc|cmd\-|co(mp|nd)|craw|da(it|ll|ng)|dbte|dc\-s|devi|dica|dmob|do(c|p)o|ds(12|\-d)|el(49|ai)|em(l2|ul)|er(ic|k0)|esl8|ez([4-7]0|os|wa|ze)|fetc|fly(\-|_)|g1 u|g560|gene|gf\-5|g\-mo|go(\.w|od)|gr(ad|un)|haie|hcit|hd\-(m|p|t)|hei\-|hi(pt|ta)|hp( i|ip)|hs\-c|ht(c(\-| |_|a|g|p|s|t)|tp)|hu(aw|tc)|i\-(20|go|ma)|i230|iac( |\-|\/)|ibro|idea|ig01|ikom|im1k|inno|ipaq|iris|ja(t|v)a|jbro|jemu|jigs|kddi|keji|kgt( |\/)|klon|kpt |kwc\-|kyo(c|k)|le(no|xi)|lg( g|\/(k|l|u)|50|54|\-[a-w])|libw|lynx|m1\-w|m3ga|m50\/|ma(te|ui|xo)|mc(01|21|ca)|m\-cr|me(rc|ri)|mi(o8|oa|ts)|mmef|mo(01|02|bi|de|do|t(\-| |o|v)|zz)|mt(50|p1|v )|mwbp|mywa|n10[0-2]|n20[2-3]|n30(0|2)|n50(0|2|5)|n7(0(0|1)|10)|ne((c|m)\-|on|tf|wf|wg|wt)|nok(6|i)|nzph|o2im|op(ti|wv)|oran|owg1|p800|pan(a|d|t)|pdxg|pg(13|\-([1-8]|c))|phil|pire|pl(ay|uc)|pn\-2|po(ck|rt|se)|prox|psio|pt\-g|qa\-a|qc(07|12|21|32|60|\-[2-7]|i\-)|qtek|r380|r600|raks|rim9|ro(ve|zo)|s55\/|sa(ge|ma|mm|ms|ny|va)|sc(01|h\-|oo|p\-)|sdk\/|se(c(\-|0|1)|47|mc|nd|ri)|sgh\-|shar|sie(\-|m)|sk\-0|sl(45|id)|sm(al|ar|b3|it|t5)|so(ft|ny)|sp(01|h\-|v\-|v )|sy(01|mb)|t2(18|50)|t6(00|10|18)|ta(gt|lk)|tcl\-|tdg\-|tel(i|m)|tim\-|t\-mo|to(pl|sh)|ts(70|m\-|m3|m5)|tx\-9|up(\.b|g1|si)|utst|v400|v750|veri|vi(rg|te)|vk(40|5[0-3]|\-v)|vm40|voda|vulc|vx(52|53|60|61|70|80|81|83|85|98)|w3c(\-| )|webc|whit|wi(g |nc|nw)|wmlb|wonu|x700|yas\-|your|zeto|zte\-/i.test(a.substr(0,4)))window.is_mobile=b})(navigator.userAgent||navigator.vendor||window.opera,true);
</script>
  <style type="text/css" media="all">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</style>
  <link rel="amphtml" href="">                                            
  <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","headline":"Hasbro Reveals Razor Crest Toy And Other New Star Wars Figures","mainEntityOfPage":"https:\/\/emptylighthouse.comhasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875","datePublished":"2020-09-26T02:56:05-04:00","dateModified":"2020-09-26T02:56:05-04:00","author":{"@type":"Person","name":"Damian Seeto"},"publisher":{"@type":"Organization","name":"Empty Lighthouse Magazine","logo":{"@type":"ImageObject","url":"https:\/\/emptylighthouse.com\/sites\/all\/themes\/emptylighthouse\/images\/logo.png","width":260,"height":60}},"image":{"type":"ImageObject","url":"https:\/\/emptylighthouse.com\/s3\/files\/styles\/696x_amp\/public\/field\/image\/star-wars-hasbro-razor-crest-no-panel-front-j832f.jpg?itok=NQiQQ02H","height":450,"width":696}}</script>
  <!-- FORNEWOR -->
  <script async type="text/javascript" src="//cdn.thisiswaldo.com/static/js/865.js"></script>

</head>

<body class="page_post html not-front not-logged-in no-sidebars page-node page-node- page-node-35127 node-type-article" >

    
<div class="layout">
  
  <header class="header" role="banner">
  <div class="header__wrapper">
    <a class="header__site" href="/">
      <img class="header__logo" src="/sites/all/themes/emptylighthouse/images/logo.svg" id="img_logo" alt="Empty Lighthouse Logo">
    </a>
    <div class="header__burger">
      <div class="header__burger-ico"></div>
    </div>
    <div class="header__panel">
      <div class="header__social">
	<a class="header__network" href="https://www.facebook.com/EmptyLighthouse/" target="_blank">
	  <div class="header__ico" id="img_fb"></div>
	</a>
	<a class="header__network" href="https://twitter.com/EmpLighthouse" target="_blank">
	  <div class="header__ico" id="img_tw"></div>
	</a>
	<a class="header__network" href="https://plus.google.com/105303974490385489945" target="_blank">
	  <div class="header__ico" id="img_gp"></div>
	</a>
      </div>
      <a class="header__more" href="#">More</a>
<!--      <a class="header__jr" href="#"><img src="/sites/all/themes/emptylighthouse/images/header_jr.svg?v=1471390746691" alt="" id="img_jr"></a> -->
      <ul class="header__nav">
	<li class="header__page"><a class="header__link" href="/category/tvfilm">TV</a></li>
	<li class="header__page"><a class="header__link" href="/category/music">Music</a></li>
	<li class="header__page"><a class="header__link" href="/category/celebs">Celebs</a></li>
	<li class="header__page"><a class="header__link" href="/category/politics">Politics</a></li>
	<li class="header__page"><a class="header__link" href="/category/tech">Tech</a></li>
	<li class="header__page"><a class="header__link" href="/category/opinions">Opinions</a></li>
      </ul>
    </div>
  </div>
  <div class="header__more_box">
    <ul class="header__nav">
      <li class="header__page"><a class="header__link" href="/category/art">Art</a></li>
      <li class="header__page"><a class="header__link" href="/category/healthliving">Health and Living</a></li>
      <li class="header__page"><a class="header__link" href="/category/moneybusiness">Money and Business</a></li>
    </ul>
  </div>
</header>

  
  <div class="content">
    <div class="content__inner">
      
      <div class="content__layout">
	<main class="content__main" role="main">
	  <div class="content__adv">
	    <div style="margin-left: -20px;width: 728px;height: 90px;margin-top: -20px;padding: 0;">

	      <script id="s869" type="text/javascript" src="/bs/?p=869&t=1&w=728&h=90&sid=s869"></script> 

	    </div>
	  </div>
	  
	  	  
	  	  
	  	  
	  	  	  
	    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
<article id="node-35127" class="post node node-article node-promoted clearfix" about="/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875" typeof="sioc:Item foaf:Document">
  <header class="post__header">
    <h1><a href="/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875">Hasbro Reveals Razor Crest Toy And Other New Star Wars Figures</a></h1>
  </header>

  
  <aside class="post__info">
    <div class="post__author">
      <div class="post__photo">
      </div>
      <div class="post__meta">
	<div class="post__name">By <b><span rel="sioc:has_creator"><span class="username" xml:lang="" about="/me/damian-seeto" typeof="sioc:UserAccount" property="foaf:name" datatype="">Damian Seeto</span></span></b></div>
	<time class="post__date"><span property="dc:date dc:created" content="2020-09-26T02:56:05-04:00" datatype="xsd:dateTime">Sat, 09/26/2020 - 02:56</span></time>
      </div>
    </div>
    <div class="post__counter">
      <a class="post__network" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Femptylighthouse.com%2Fhasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875"><div id="img_post_fb"></div></a>
      <a class="post__network" href="https://twitter.com/home?status=https%3A%2F%2Femptylighthouse.com%2Fhasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875"><div id="img_post_tw"></div></a>
      <a class="post__network" href="https://plus.google.com/share?url=https%3A%2F%2Femptylighthouse.com%2Fhasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875"><div id="img_post_gp"></div></a>
      <a class="post__network" href="http://www.tumblr.com/share/link?url=https%3A%2F%2Femptylighthouse.com%2Fhasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875"><div id="img_post_tu"></div></a>
      <div class="post__number">ELH</div>
    </div>
  </aside>

  <div class="post__cover">
    <img typeof="foaf:Image" src="https://emptylighthouse-production.s3-us-west-2.amazonaws.com/s3fs-public/styles/728x_hero/public/field/image/star-wars-hasbro-razor-crest-no-panel-front-j832f.jpg?itok=TeM5xQB9" alt="" />  </div>

  
  <div class="post__content">    
    <div class="element-invisible"><a id="main-content"></a></div>
        
    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><div style="margin-left: -20px">
  <center>
  </center>
</div><p><span class="beginletter">H</span>asbro has gotten all out today revealing several new toys for the ever popular Star Wars brand. The biggest announcement is a Vintage Collection style Razor Crest as well as several new Black Series figures.</p>
<p>The Razor Crest from The Mandalorian will be a part of Haslab. This means the project will only go ahead if there are over 6000 backers.</p>
<div style="margin-left: -20px">
  <center>
  </center>
</div><p>As of time of writing, there are well over 4000 backers so the project will be successful. It comes with a 3.75 inch scale Razor Crest as well as a Mandalorian figure with his Beskar armor.</p>
<p>If you can afford to back the toy, it will cost you $349.99 USD. The toy will be released sometime in Fall 2021 if it's successful. You can read the official features below as provided by <a href="https://hasbropulse.com/products/star-wars-the-vintage-collection-razor-crest?fbclid=IwAR1CJjiviSAnuRRchRr-_-Ta_r5qJbZjGvFBWS2cJyLqGukVMP1BWuG3jkw">Hasbro</a>.</p>
<div style="margin-left: -20px">
  <center>
  </center>
</div><ul><li>The cockpit opens to reveal a fully detailed interior with three seats that fit Vintage Collection figures</li>
<li>Detachable engines and removeable hull panels to recreate the season 1 scenes of the Jawas breaking down the ship for scrap</li>
<li>&nbsp;A weapons locker with included, removeable, show-inspired weapons accessories to make sure your figures are always ready for whatever the galaxy throws at them</li>
<li>A carbon freezing chamber and cargo hold with cargo netting</li>
<li>Bounty hunters can make an entrance &mdash; or a fast exit &mdash; with opening rear and side doors and lowering ramps</li>
<li>Removeable landing gear</li>
<li>Bunk area with space for a figure to hide</li>
</ul><div style="margin-left: -20px">
  <center>
  </center>
</div><p>In related news, many new Black Series toys have also been revealed. As reported by <a href="https://screenrant.com/star-wars-black-series-dark-rey-boba-fett-jar-jar-binks/">Screen Rant</a>, five new figures have been announced that should be out by Spring 2021.</p>
<p>The first is the Dark Side Rey that featured in The Rise of Skywalker. We also get a deluxe figure for Jar Jar Binks and a Return of the Jedi version of Boba Fett. These deluxe figures will cost $29.99 USD.</p>
<div style="margin-left: -20px">
  <center>
  </center>
</div><p>The last two figures is a Clone Trooper from The Clone Wars and even an Incinerator Stormtrooper as seen in Season One of The Mandalorian.</p>
<div style="margin-left: -20px">
  <center>
  </center>
</div><p>
  Wanna read more on this? Check these out:
  Star Wars Qui Gon Jinn Figure Revealed By Hot Toys (<a href="/star-wars-qui-gon-jinn-figure-revealed-hot-toys-1974022100">more</a>); 
  Mattel Reveals New Babu Frik Plush From Star Wars: The Rise of Skywalker (<a href="/mattel-reveals-new-babu-frik-plush-star-wars-rise-skywalker-1642892717">more</a>); 
  Star Wars UCS Mos Eisley Cantina Lego Set Revealed (<a href="/star-wars-ucs-mos-eisley-cantina-lego-set-revealed-1751628427">more</a>); 
  Star Wars: The Rise of Skywalker Jet Trooper Hot Toys Revealed  (<a href="/star-wars-rise-skywalker-jet-trooper-hot-toys-revealed-1167128217">more</a>).</p><div style="margin-left: -20px">
  <center>
  </center>
</div><p>And here are some more related articles: 
  Star Wars: Squadrons Single Player Trailer Released (<a href="/star-wars-squadrons-single-player-trailer-released-2009745111">more</a>); 
  Disney/Lucasfilm Taking A Step Back From Star Wars Movies (<a href="/disneylucasfilm-taking-step-back-star-wars-movies-608104354">more</a>); 
  Lego Star Wars Holiday Special Coming To Disney+ (<a href="/lego-star-wars-holiday-special-coming-disney-540028034">more</a>).</p><p>A few more: 
  New Star Wars The Vintage Collection Millennium Falcon Announced By Hasbro (<a href="/new-star-wars-vintage-collection-millennium-falcon-announced-hasbro-1545810097">more</a>); 
  Star Wars: The Clone Wars Getting Black Series Toys (<a href="/star-wars-clone-wars-getting-black-series-toys-1585816008">more</a>).
  </p>
<div style="margin-left: -20px">
  <center>
  </center>
</div>
</div></div></div><div class="field field-name-field-image-credit field-type-text field-label-hidden"><div class="field-items"><div class="field-item even"><p>Hasbro</p>
</div></div></div>    
  </div>
</article>
  </div>
</div>
  </div>
	  
	  <aside class="post__footer">
	    
	    	    
	  </aside>
	</main>
	
	<aside class="content__sidebar">
	  
	    <div class="region region-content-sidebar">
    <div id="block-block-1" class="content__box">
<!--  <header class="content__header">
    <h3>Sponsors</h3>
  </header> -->
  <div class="content__adv">
    <div id="waldo-tag-866"></div>  </div>
</div>
<div id="block-block-2" class="content__box">
<!--  <header class="content__header">
    <h3>Sponsors</h3>
  </header> -->
  <div class="content__adv">
    <div id="waldo-tag-867"></div>
  </div>
</div>
<div id="block-search-form" class="block block-search">

    
  <div class="content">
    <form action="/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="content__box search">
  <header class="content__header">
    <h3>Search</h3>
  </header>
  <div class="content__adv">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-wrGqQMnh40TsJS4RTb4QFyjYhymE8z0z33CekF_lTrw" />
<input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div>
</div></form>  </div>
</div>
<div id="block-block-6" class="content__box">
<!--  <header class="content__header">
    <h3>Sponsors</h3>
  </header> -->
  <div class="content__adv">
    <div id="waldo-tag-868"></div>
  </div>
</div>
<div id="block-block-9" class="content__box">
<!--  <header class="content__header">
    <h3>Sponsors</h3>
  </header> -->
  <div class="content__adv">
    <div id="waldo-tag-872"></div>  </div>
</div>
  </div>
	  
	</aside>
      </div>
      
    </div>
  </div>
  
  <footer class="footer" role="contentinfo">
  <div class="footer__main">
    <div class="footer__inner">
      <nav class="footer__nav">
	<div class="footer__site">
	  <a class="footer__home" href="#"><img class="footer__logo" src="/sites/all/themes/emptylighthouse/images/logo_footer.svg?v=1471390746691" alt=""></a>
	  <div class="footer__address">
	    6 Liberty Square #2027<br>
        Boston, MA 02109<br>
	    Phone 617-804-6050<br>
	    Fax 617-935-0038
	  </div>
	</div>
	<div class="footer__menu">
	  <ul class="footer__list">
	    <li class="footer__item"><h3 class="footer__title">Company</h3></li>
	    <li class="footer__item"><a class="footer__link" href="/terms">Terms & Conditions</a></li>
	    <li class="footer__item"><a class="footer__link" href="/privacy">Privacy Policy</a></li>
	    <li class="footer__item"><a class="footer__link" href="/contact">Contact Us</a></li>
	    <li class="footer__item"><a class="footer__link" href="#">FAQs</a></li>
	  </ul>
	  <ul class="footer__list">
	    <li class="footer__item"><h3 class="footer__title">About</h3></li>
	    <li class="footer__item"><a class="footer__link" href="/writers">Writers</a></li>
	    <li class="footer__item"><a class="footer__link" href="#">Editorial</a></li>
	    <li class="footer__item"><a class="footer__link" href="/join">Join Us</a></li>
	    <li class="footer__item"><a class="footer__link" href="#">Store</a></li>
	  </ul>
	  <ul class="footer__list">
	    <li class="footer__item"><h3 class="footer__title">Resources</h3></li>
	    <li class="footer__item"><a class="footer__link" href="#">Blog</a></li>
	    <li class="footer__item"><a class="footer__link" href="http://eepurl.com/ciPJIT">Subscribe</a></li>
	    <li class="footer__item"><a class="footer__link" href="https://www.facebook.com/EmptyLighthouse">Facebook</a></li>
	    <li class="footer__item"><a class="footer__link" href="https://twitter.com/emplighthouse">Twitter</a></li>
	  </ul>
	</div>
      </nav>
    </div>
  </div>
  
  <div class="footer__copyright">
    <div class="footer__inner">
      <div style="height:90px;border:0;padding:0">	

      </div>

      © 2016-2019 - A product of Westbourne International, LLC
    </div>
  </div>
</footer>
  
</div>
  <script type="text/javascript" defer="defer" src="//ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js" onload="if(jQuery.isFunction(jQuery.holdReady)){jQuery.holdReady(true);jQuery.holdReady(true);}"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
function advagg_mod_4(){advagg_mod_4.count=++advagg_mod_4.count||1;try{if(advagg_mod_4.count<=40){window.jQuery||document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.10/jquery.min.js'>\x3C/script>");advagg_mod_4.count=100}}catch(e){if(advagg_mod_4.count>=40){throw e}else window.setTimeout(advagg_mod_4,250)}}
function advagg_mod_4_check(){if(window.jQuery&&window.Drupal&&window.Drupal.settings){advagg_mod_4()}else window.setTimeout(advagg_mod_4_check,250)};advagg_mod_4_check();
//--><!]]>
</script>
<script type="text/javascript" async="async" src="https://cdn.rawgit.com/bramstein/fontfaceobserver/v2.1.0/fontfaceobserver.js"></script>
<script type="text/javascript" src="https://emptylighthouse.com/sites/default/files/advagg_js/js__H5AFmq1RrXKsrazzPq_xPQPy4K0wUKqecPjczzRiTgQ__JIy-3lUpq3qC8JjvfOMkqOB8loYzuE93VQgLvC7HpVM__X3J5iaTDAJV5jEkMptZUC44ftTNfpiOKLspZWdcu7A8.js" defer="defer" onload="function advagg_mod_3(){advagg_mod_3.count=++advagg_mod_3.count||1;try{if(advagg_mod_3.count<=40){init_drupal_core_settings();advagg_mod_3.count=100}}catch(e){if(advagg_mod_3.count>=40){throw e}else window.setTimeout(advagg_mod_3,1)}}
function advagg_mod_3_check(){if(window.init_drupal_core_settings&&window.jQuery&&window.Drupal){advagg_mod_3()}else window.setTimeout(advagg_mod_3_check,1)};advagg_mod_3_check();"></script>
<script type="text/javascript" src="https://emptylighthouse.com/sites/default/files/advagg_js/js__tva8i4clrMSUirkNdhClYnJBktF7vXBb9OOLTyqg1lQ__cE_skSvRXNHT1nTB7eFtgNrYSNYMca_AOMBMiIcmxwI__X3J5iaTDAJV5jEkMptZUC44ftTNfpiOKLspZWdcu7A8.js" defer="defer"></script>
<script type="text/javascript" src="https://emptylighthouse.com/sites/default/files/advagg_js/js__HxTbhN-HTG8H6pU8ZNTXLhmTeg8fhzG_sbeVLz0gBqU__AdhAFZ5QAk_VrKkFUOCnxJb9ANrhuWlKf15A7QHm14M__X3J5iaTDAJV5jEkMptZUC44ftTNfpiOKLspZWdcu7A8.js" defer="defer" async="async"></script>
<script type="text/javascript" src="https://emptylighthouse.com/sites/default/files/advagg_js/js__edZMtwzzQLhm8rSmqshrc3Z_IqrOQhy6ngzPTSEYWMY__Q1sWcT_7lOB2DdbQnhIfIbi5YlThPi4Sl3-1sN5QzHU__X3J5iaTDAJV5jEkMptZUC44ftTNfpiOKLspZWdcu7A8.js" defer="defer"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
function init_drupal_core_settings() {jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"emptylighthouse","theme_token":"xNodp1TVYnyGR7n4LaPBPIQufK3TEJj9Afw1vkWdskg","css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"sites\/all\/modules\/emptylighthouse\/css\/styles.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/themes\/emptylighthouse\/css\/styles.css":1},"js":{"\/\/ajax.googleapis.com\/ajax\/libs\/jquery\/1.10.2\/jquery.min.js":1,"https:\/\/cdn.rawgit.com\/bramstein\/fontfaceobserver\/v2.1.0\/fontfaceobserver.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/emptylighthouse\/js\/jquery.inview.min.js":1,"sites\/all\/modules\/emptylighthouse\/js\/sticky-sidebar.js":1,"sites\/all\/modules\/emptylighthouse\/js\/common.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"sites\/all\/modules\/advagg\/advagg_font\/advagg_font.js":1,"sites\/all\/themes\/emptylighthouse\/js\/common.js":1}},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"advagg_font":{"avenir":"Avenir","times-new-roman":"Times New Roman","abel":"Abel"},"advagg_font_storage":1,"advagg_font_cookie":1,"advagg_font_no_fout":1,"urlIsAjaxTrusted":{"\/hasbro-reveals-razor-crest-toy-and-other-new-star-wars-figures-413680875":true}}); 
if(jQuery.isFunction(jQuery.holdReady)){jQuery.holdReady(false);}} if(window.jQuery && window.Drupal){init_drupal_core_settings();}
//--><!]]>
</script>


  <!-- FORNEWOR -->
  <div id="waldo-tag-871"></div>

  <!-- BIT FLX -->
  <script>
    cf_page_artist = "";
    cf_page_song = "";
    cf_page_header = ".header";
    cf_page_footer = ".footer";
    cf_page_element = ".content .content__layout";
    cf_adunit_id = "39384328";
    cf_flex = true;
  </script>
  <script src="//srv.clickfuse.com/showads/showad.js"></script>
  
</body>
</html>
